Wednesday, 21 June 2017

Some random notes on losing my broadband connection

I first started using Ubuntu just a few weeks after Lucid Lynx was released and have used Ubuntu, Kubuntu, Xubuntu, Lubuntu and Ubuntu GNOME since then. Towards the end of 2016 I took early retirement and decided to curtail some of my Ubuntu related activities in favour of some long abandoned interests which went back to the 1960s. Although I had no intention of spending every day sat in front of a computer screen I still wished to contribute to Ubuntu but at a reduced level. However, recent problems relating to my broadband connection, which I am hoping are now over, prompted me to look closely at how I could continue to contribute to Ubuntu if I lost my "always on" internet.

Problems

Thanks to my broadband provider, whose high profile front man sports a beard and woolly jumpers, my connection changed from being one that was "always on" to one that was "usually off". There's a limit to how many times I'm prepared to reboot my cable modem on the advice of the support desk, be sent unnecessary replacement modems because the one I'm using must be faulty, to allow engineers into my home to measure signal levels, and be told the next course of action will definitely get my connection working only to find that I'm still off-line the next day and the day after. I kept asking myself: "Just how many engineers will they need to send before someone successfully diagnoses the problem and fixes it?"

Mobile broadband

Much of my recent web browsing, on-line banking, and updating of my Xubuntu installations has been done with the aid of two iPhones acting as access points while connected to the 3 and EE mobile networks. It was far from being an ideal situation, connection speeds were often very low by today's standards but "it worked" and the connections were far more reliable than I thought that they would be. A recent test during the night showed a download speed on a 4G connection to be comparable to that offered by many other broadband providers. But downloading large Ubuntu updates took a long time especially during the evening. As updating the pre-installed apps on a smart phone can quickly use up one's monthly data allowance I made myself aware of where I could find local Wi-Fi hotspots to make some of the important or large phone updates and save some valuable bandwidth for Ubuntu. Interestingly with the right monthly plan and using more appropriate hardware than a mobile phone, I could actually save some money by switching from cable to mobile broadband although I would definitely miss my 100Mb/s download speed that is most welcome when downloading ISO images or large Ubuntu updates.

ISO testing

Unfortunately these problems, which lasted for over three weeks, meant that I had to cease ISO testing due to the amount of data I would need to download several times each week. I had originally intended to get a little more involved with testing of the development release of Xubuntu during the Artful cycle but those plans were put on hold while I waited for my broadband connection to be restored and deemed to be have been fixed permanently. During this outage I still managed to submit a couple of bug reports and comment on a few others but my "always on" high speed connection was very much missed.

Connection restored!

How I continue with Ubuntu long-term will now depend on the reliability of my broadband connection which does seem to have now been restored to full working order. I'm finalising this post a week after receiving yet another visit from an engineer who restored my connection in just a matter of minutes. Cables had been replaced and signal levels had been measured and brought to within the required limits. Apparently the blame for the failure of the most recent "fix" was put solely on one of his colleagues who I am told failed to correctly join two cables together. In other words, I wasn't actually connected to their network at all. It must have been so very obvious to my modem/router which sat quietly in the corner of the room forever looking to connect to something that it just could not find and yet was unable to actually tell me so. If only such devices could actually speak....

4 comments:

  1. One thing I've found very useful is that, depending on the modem, it may actually offer statistics of exactly that sort. My modem, a Motorola SB6141, is visible on the local network as 192.168.100.1 (as opposed to the router between me and it, which is the usual 192.168.1.1), and offers DOCSIS status and link training information.

    Sadly, most combined modem/router units don't expose that info, along with various other suboptimal behaviors.

    You might want to look into picking one up; they're not expensive, are supported on nearly every cable internet provider, and can remove a surcharge from your bill. (Around here, rental is $7/mo - it paid for itself in half a year.)

    My router's a TP-Link Archer C7 running OpenWRT, which I am similarly pleased with.

    ReplyDelete
    Replies
    1. Thanks for your comments Alex.

      Different countries, different providers, different rules.

      Delete
  2. Received from "Wayne" by email:

    Virgin Media do not allow you to change the hub for a 3rd party one,
    However they do expose the power/signal levels on the hub's status page,
    maybe you could get a raspberry pi + 3g module plus a short script to
    monitor then send you a telegram message, when they start to drop.......

    ReplyDelete
    Replies
    1. I didn't think I could use my own equipment to connect to VM and wouldn't even if it was allowed. Too much hassle with the support desk when things go wrong.

      I don't believe the power levels were at fault anyway. It would take me far too long to recount everything that happened during my three week outage but three things are now very clear:

      1) Each engineer can interpret out of range power levels differently.
      2) The cable from my home did need replacing.
      3) Shoddy workmanship resulted in an increased outage unnecessarily.

      My Hub now shows an uptime of 9 days and 20 hours. In that time I've not noticed any outages and have had no need to even think about a reboot.

      I'm back!

      Delete